ZABBIX BUGS AND ISSUES
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-2624

Alerts do not sent when monitoring log or trapper item

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.8.2
    • Fix Version/s: 1.8.3
    • Component/s: Server (S)
    • Labels:
      None
    • Environment:
      zabbix 1.6.x , 1.8.x

      Description

      Monitoring configurations are followings.

      Item configuration:

      • Description: Log of $1
      • Key: log[/tmp/test.log]
      • Type: Zabbix Agent (Active)
      • Type of information: Log

      Trigger configuration:

      • Descriptopn: Error log
      • Expression: {Zabbix Server:log[/tmp/test.log].str(error)}

        =1

      • Event generation: Normal + Multiple TRUE events

      Action configuration:

      • Name: alert mail
      • Event source: Trigger
      • Enable escalations: Uncheck
      • Default subject/message: Default
      • Recovery message: Check
      • Recovery subject/message: default
      • Action conditions: Trigger value = PROBLEM
      • Action operations: Send message to User "Admin"

      I added following lines to /tmp/test.log, but messages do not sent. (screenshot 1-1, 1-2)

      ----------
      warning
      error
      error
      error
      warning
      warning
      error
      warning
      ----------

      It seems that the cause of this problem is handling of inserting event to escalation table and escalator process.
      I created the patch for this problem, and added the same lines to /tmp/test.log. (screenshot 2-1, 2-2)
      Then, I tested uncheck "Recovery message" case. (screenshot 3-1, 3-2)

      I would appreciate it if you could review this patch and fix this problem!

      1. zabbix-1.8.2-sending_each_alert_for_logmonitoring.patch
        2 kB
        Kodai Terashima
      1. screenshot 1-1.jpg
        95 kB
      2. screenshot 1-2.jpg
        124 kB
      3. screenshot 2-1.jpg
        96 kB
      4. screenshot 2-2.jpg
        118 kB
      5. screenshot 3-1.jpg
        94 kB
      6. screenshot 3-2.jpg
        115 kB

        Issue Links

          Activity

          richlv added a comment -

          i recall a couple of issues with alerter being fixed for 1.8.3 - have you tried with svn head ?

          Aleksandrs Saveljevs added a comment -

          Indeed, this problem should have been fixed by ZBX-2305.

          Kodai Terashima added a comment -

          Oops sorry, please close this issue.

          Aleksandrs Saveljevs added a comment -

          Thanks for the quick update!


            People

            • Assignee:
              Unassigned
              Reporter:
              Kodai Terashima
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: