ExportXMLWordPrintable

    • Type: Problem report
    • Resolution: Fixed
    • Priority: Critical
    • 7.0.32rc1, 7.4.16rc1, 8.0.0rc1
    • Affects Version/s: 7.0.28
    • Component/s: API (A)
    • None
    • S26-W30/31, S26-W32/33, S26-W34/35, S26-W36/37, S26-W38/39, S26-W40/41
    • 0.25
    • 1

      If host is monitored by proxy group, remote scripts can't be executed even if assigned proxy has parameter EnableRemoteCommands=1 set.

      To enable remote script execution for hosts monitored by proxy group, it is necessary to set server parameter EnableGlobalScripts=1.

      Steps to reproduce:

      1. Create environment with server, proxy and agent;
      2. Set EnableRemoteCommands=1 in proxy config;
      3. Create proxy group containing the proxy and add new host monitored by this proxy group;
      4. Try to execute ping script under Monitoring -> Latest data -> Host.

      Result:

      Script fails with error "Global script execution on Zabbix server is disabled by server configuration." unless server setting EnableGlobalScripts=1

      Expected:

      Since host is monitored by proxy assigned via proxy group, script execution should work as long as proxy setting EnableRemoteCommands=1

            Assignee:
            Sergejs Cernisenko
            Reporter:
            Aleksejs Brizgalovs
            Team B
            Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

              Created:
              Updated:
              Resolved:

                Estimated:
                Original Estimate - 5h Original Estimate - 5h
                5h
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 18h 25m
                18h 25m