If host is monitored by proxy group, remote scripts can't be executed even if assigned proxy has parameter EnableRemoteCommands=1 set.
To enable remote script execution for hosts monitored by proxy group, it is necessary to set server parameter EnableGlobalScripts=1.
Steps to reproduce:
- Create environment with server, proxy and agent;
- Set EnableRemoteCommands=1 in proxy config;
- Create proxy group containing the proxy and add new host monitored by this proxy group;
- Try to execute ping script under Monitoring -> Latest data -> Host.
Result:
Script fails with error "Global script execution on Zabbix server is disabled by server configuration." unless server setting EnableGlobalScripts=1
Expected:
Since host is monitored by proxy assigned via proxy group, script execution should work as long as proxy setting EnableRemoteCommands=1