Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-3166

templated applications do not work properly

    Details

    • Type: Incident report
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.8.4rc1
    • Fix Version/s: 1.8.6
    • Component/s: Frontend (F)
    • Labels:
      None

      Description

      Main issues:

      (1) Create host H, template T1, template T2. Create applications with the same name in H and T2. Link T1 to H. Link T2 to T1. Observe template-updated.png. Templates are linked, but there is no application in T1 and H's application does not say it comes from T2. Items, triggers, and graphs are OK.

      (2) Create host H, template T1. Create application A on T1, link T1 to H. Unlink T1 from H. Go to applications of H. Observe linked-application.png, even though T1 is no longer linked to T1.

      Minor issues:

      (3) If a host's application comes from a template, the link to the template is shown in blue. It is gray in items, triggers, and graphs.

      (4) Also, when creating an application it should not be possible to press "Empty" button to select no host.

      Blocker, because in (2) the database gets corrupted.

        Attachments

        1. linked-application.png
          83 kB
          Aleksandrs Saveljevs
        2. template-updated.png
          103 kB
          Aleksandrs Saveljevs

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                asaveljevs Aleksandrs Saveljevs
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: