ZABBIX BUGS AND ISSUES
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-3918

Failure to update the template when inherit an item

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.9.5 (alpha)
    • Fix Version/s: 1.9.5 (alpha)
    • Component/s: Frontend (F)
    • Labels:
      None
    • Environment:
      CentOS 5.5, IE8

      Description

      Возможно ошибка в файле class.citem.php строка 1221
      Старая: else if(($exItem['templateid'] > 0) && (bccomp($exItem['templateid'],$item['itemid']) != 0)){
      Должно быть: else if(($exItem['templateid'] > 0) && (bccomp($exItem['templateid'],$item['templateid']) != 0)){

      1. screenshot-1.jpg
        243 kB
      2. screenshot-2.jpg
        340 kB
      3. screenshot-3.jpg
        226 kB

        Activity

        Oleksiy Zagorskyi added a comment -

        It seems it's not a bug, such behavior is by design.

        Victor Bashkirov added a comment - - edited

        This problem is normally working in zabbix 1.8.5 in such a data structure

        Victor Bashkirov added a comment -

        All delete and create now. No problem.

        richlv added a comment -

        reopening to update summary


          People

          • Assignee:
            Unassigned
            Reporter:
            Victor Bashkirov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: