Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.9.6 (beta), 1.9.7 (beta)
    • Fix Version/s: None
    • Component/s: Installation (I)
    • Labels:
    • Environment:

      Description

      I got an compile error when I tried to compile it with "configure --enable-agent":

      ...
      gcc -DHAVE_CONFIG_H -I. -I../../../include     -g -O2   -MT comms.o -MD -MP -MF .deps/comms.Tpo -c -o comms.o comms.c
      /tmp/ccKyOdt8.s: Assembler messages:
      /tmp/ccKyOdt8.s:12: Error: Incorrect register `%rax' used with `l' suffix
      /tmp/ccKyOdt8.s:120: Error: Incorrect register `%rdx' used with `l' suffix
      /tmp/ccKyOdt8.s:120: Error: Incorrect register `%rax' used with `l' suffix
      ...
      

        Activity

        Hide
        Aleksandrs Saveljevs added a comment -

        It is highly unlikely that this is a Zabbix problem. The only place where we do something low-level is src/libs/zbxnix/fatal.c, but even there it is just portable C. Please check your compiler and build environment.

        Show
        Aleksandrs Saveljevs added a comment - It is highly unlikely that this is a Zabbix problem. The only place where we do something low-level is src/libs/zbxnix/fatal.c, but even there it is just portable C. Please check your compiler and build environment.
        Hide
        Igor Danoshaites added a comment -

        Hi,

        Can not reproduce the same problem on our test env (RedHat EL 5.3, x64) when using "./configure --enable-agent" command for zabbix-1.9.7.

        As Aleksandrs wrote you on 2011 Nov 04 09:01, you should check your build environment and used compiler.

        Closing this issue with resolution "Can not reproduce".

        Show
        Igor Danoshaites added a comment - Hi, Can not reproduce the same problem on our test env (RedHat EL 5.3, x64) when using "./configure --enable-agent" command for zabbix-1.9.7. As Aleksandrs wrote you on 2011 Nov 04 09:01, you should check your build environment and used compiler. Closing this issue with resolution "Can not reproduce".

          People

          • Assignee:
            Unassigned
            Reporter:
            Guoyu Li
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: