ZABBIX BUGS AND ISSUES
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-4467

Screen - Select Zoom "ALL" -> Warning. Time period max value: 63072000 (730 d)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.9 (beta)
    • Fix Version/s: 1.9.9 (beta), 2.0.0rc1
    • Component/s: Frontend (F)
    • Labels:
    • Environment:
      Zabbix-1.9.9-23907
      CentOS 6.0
      MySQL 5.5.19

      Description

      If a user selects "ALL" in zoom while viewing SCREENS, even if there is only a few weeks of data, the zoom goes out to 2 years and displays the following message: Warning. Time period max value: 63072000 (730 d).

        Activity

        Alexander Sorokin added a comment -

        Fixed in development branch svn://svn.zabbix.com/branches/dev/ZBX-4467

        richlv added a comment - - edited

        (2) as discussed with zalex, string change that only changed [] to "" should also be reflected in all translations that had those strings translated. it should be made so that these translations are not lost (both msgid and msgstr must be properly changed). it should not be changed for languages that didn't have those strings translated.
        if in doubt, consult translation maintainers : https://zabbix.org/wiki/Translating_Zabbix

        <pavels> But he didn't change only of those strings. Or am I missing something?

        <richlv> this was my failure, commented on the wrong issue. added (30) to ZBX-2737 instead, CLOSED here

        Pavels Jelisejevs added a comment - - edited

        (3) Since we have a nice _n() function, let's use it in graphs.inc.php:378 and :382.
        <sanja> RESOLVED

        <pavels> CLOSED.

        Pavels Jelisejevs added a comment -

        Merged to trunk r25017.

        CLOSED.

        richlv added a comment - - edited

        (4) regression. set ZBX_MAX_PERIOD to 10 years, have 5 years worth of data. in a graph, click "all" - it goes to two years. try this in rev 25016 - it goes to whatever amount of data you have

        <pavels> RESOLVED in /branches/dev/ZBX-4467.

        <richlv> functionally seems to work as expected again, CLOSED

        Eduards Samersovs added a comment - - edited

        (5) Will be nice to crop slider till max period size in event when user make it bigger.

        <pavels> I've talked to Alexander about that, and we've decided to fix this as a separate issue later. CLOSED.

        Eduards Samersovs added a comment -

        Tested

        Pavels Jelisejevs added a comment -

        The fix for the maximum period has been merged to trunk r25792.

        CLOSED.

        Oleksiy Zagorskyi added a comment -

        In cases like this the "Fix version/s" should contain two values: 1.9.9 and 1.9.10 because both releases have changes related to this issue.
        REOPENED

        Oleksiy Zagorskyi added a comment -

        closed again with two values


          People

          • Assignee:
            Pavels Jelisejevs
            Reporter:
            Kenneth Palmertree
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: