It's old-old idea.
I'd suggest this changes only for 2.0
For the trigger functions (regexp str) for second parameter we have description:
"Second optional parameter is number of seconds or number of lines to analyse."
It's not clear (IMO) what "lines" means.
Maybe it worth to change "of lines" to the "of historical values"?
For many other trigger functions (sum avg max min) we have short description:
"Parameter defines length of the period in seconds."
I mean #num is not mentioned. Would be better to add it with the suggestion above.
For instance a description for "count" function is much informative. I mean usage of the term "historical values":
"Number of historical values for period of time in seconds or number of last #num values matching condition."
But it could be unified too.
Description for "delta" function could be rewritten (improved).