ZABBIX BUGS AND ISSUES

API call to delete templates doesn't do anything

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Duplicate
  • Affects Version/s: 1.9.8 (beta)
  • Fix Version/s: None
  • Component/s: API (A)
  • Labels:
    None
  • Zabbix ID:
    Reviewed 2.0

Description

When attempting to use the template.delete call, the specified template(s) don't get deleted.

I tried to track the problem down, but the code is really hard to follow. So this bug serves as a host bug for all subsequent bugs I'll find.

Basically, the API call fails due to a rollback caused by invalid SQL statements.

Issue Links

Activity

Timo A. Hummel added a comment -

This issue depends on ZBX-4574

Alexei Vladishev added a comment -

Please post JSON request and response here.

Timo A. Hummel added a comment -

Call:

{"jsonrpc":"2.0","id":"4f214b173915b","auth":"aabb913b0b0a31fd8abaca630b385610","method":"template.delete","params":["10001"]}

Response:

{"templateids":["10001"]}

The bug is described in ZBX-4574, with a possible fix.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: