Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.0.0rc1
    • Fix Version/s: 2.0.0rc3
    • Component/s: Frontend (F)
    • Environment:
      Debian 6.0.3
      mysql Ver 14.14 Distrib 5.1.49, for debian-linux-gnu (x86_64)
      PHP 5.3.3-7+squeeze3 with Suhosin-Patch (cli)

      Description

      When a subfilter is active and some items are selected, a click on "Mass update" just resets the subfilter.
      The items are still selected and the next click on the button performs the mass update.

      Related:
      When there are many items and pagination is taking place, then the final mass update seems only to update the items on the current page.
      The pages have to be switched and the mass update has to be done for every page (items remain selected correctly).

        Activity

        Jens Berthold added a comment - - edited

        Please note that this bug is related, but not equal to ZBX-1158.
        By the way: is it possible to change my own issues after I created them?

        richlv added a comment -

        do you mean clicking on "go" with subfilter activated ? if so, couldn't reproduce that in trunk rev 25955.

        also couldn't reproduce issue with mass update not working properly with selection over multiple pages, works just fine here with same trunk revision

        oh, opera 11.60 on linux - which browser are you using ?

        Jens Berthold added a comment -

        Yes, I mean clicking "Go".
        I currently use Firefox 9.0.1 under Linux Mint Debian Edition.

        Jens Berthold added a comment -

        I narrowed the fault:
        This only happens when many items are selected (my profile is configured to show 200 rows per page).
        If I select 200 items and click "Go (200)", the page just reloads and nothing happens. If a subfilter is active, it is reset on the page reload.
        Maybe a problem with too long cookies or post requests?
        (Could someone change the issue title to "Mass updates fail with many items selected", please?)

        Jens Berthold added a comment -

        Please see my previous comment.

        Toms added a comment -

        Fixed in dev. branch: svn://svn.zabbix.com/branches/dev/ZBX-4739

        Toms added a comment -

        Fixed in 2.0.0rc3 r26567


          People

          • Assignee:
            Toms
            Reporter:
            Jens Berthold
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: