Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.8.11
    • Fix Version/s: None
    • Component/s: Server (S)
    • Labels:
      None

      Description

      In my environment, zabbix receives a Windows Event Log by "eventlog" item, and it is performing AlertScript as a trigger.

      I found that when the Windows Event Log exceeding 2048 characters was received, AlertScript could not be performed.

      It was outputted to zabbix_server.log as follows.

      sh: -c: line 0: unexpected EOF while looking for matching `"'
      sh: -c: line 8: syntax error: unexpected end of file

      I changed the value of MAX_STRING_LEN in common.h into 4096 and tested it.
      Then, AlertScript has been performed correctly.

      I regarded this as the same problem as ZBX-1298, but 1.8.11 was not solved.

      Are there any other workarounds?

        Issue Links

          Activity

          suzuka added a comment -

          I am in trouble that no alerts are outputted.
          I hope that it alerts of even if how many characters it is.

          Alexander Vladishev added a comment -

          It is duplicate of ZBX-4527. I'm closing the issue.


            People

            • Assignee:
              Unassigned
              Reporter:
              suzuka
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: