Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-5358

Zabbix Agent 2.0.0 on Windows - incorrect reporting of non-ASCII characters in interface name

    Details

      Description

      Zabbix Agent 2.0.2rc1 does not encode in UTF8 discovered network interface names. Agent is running on Windows XP 32bit SP3 Russian. Interface names are returned in CP1251 encoding. Created items contains "?" character instead of cyrillic symbols and its are in "unsupported" state. There are output of zabbix_get command below.

      $ zabbix_get -s 192.168.0.132 -k "system.uname"
      Windows WINXP 5.1.2600 Windows XP Service Pack 3 Intel IA-32
      
      $ zabbix_get -s 192.168.0.132 -k "agent.version"
      2.0.2rc1
      
      $ zabbix_get -s 192.168.0.132 -k "net.if.discovery"
      {
      	"data":[
      		{
      			"{#IFNAME}":"Xen Net Device Driver - ???????? ???????????? ???????"},
      		{
      			"{#IFNAME}":"MS TCP Loopback interface"}]}
      
      $ zabbix_get -s 192.168.0.132 -k "net.if.discovery" | iconv -f cp1251
      {
      	"data":[
      		{
      			"{#IFNAME}":"Xen Net Device Driver - ???????? ???????????? ???????"},
      		{
      			"{#IFNAME}":"MS TCP Loopback interface"}]}
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              fixxxer78 Alex Moskalenko
            • Votes:
              2 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: