ZABBIX BUGS AND ISSUES

Simple text in Templates is broken. "No data defined." is displayed.

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 2.0.4rc1
  • Fix Version/s: 2.0.4rc1, 2.1.0
  • Component/s: Server (S)
  • Environment:
    CentOS MySQL
    pre-zabbix-2.0.4rc1-30682
  • Zabbix ID:
    RTF
  1. screenshot-1.jpg
    305 kB
    2012 Oct 09 04:40
  2. screenshot-2.jpg
    319 kB
    2012 Oct 09 04:42
  3. screenshot-3.jpg
    152 kB
    2012 Oct 09 13:04
  4. screenshot-4.jpg
    298 kB
    2012 Oct 17 08:27
  5. screenshot-5.jpg
    211 kB
    2012 Oct 17 08:29
  6. screenshot-6.jpg
    362 kB
    2012 Oct 17 13:18

Activity

Hide
richlv added a comment -

could you please clarify what's "simple text" and where exactly do you see it ?

Show
richlv added a comment - could you please clarify what's "simple text" and where exactly do you see it ?
Hide
Victor Bashkirov added a comment - - edited

Sorry. In the English version field is "Plain Text".
Added screenshots.

Show
Victor Bashkirov added a comment - - edited Sorry. In the English version field is "Plain Text". Added screenshots.
Hide
Alexei Vladishev added a comment -

It should be fixed if reproducible.

Show
Alexei Vladishev added a comment - It should be fixed if reproducible.
Hide
richlv added a comment -

but does the item have the data for that period ?
if you select 6 hours or a day, does data appear ?

Show
richlv added a comment - but does the item have the data for that period ? if you select 6 hours or a day, does data appear ?
Hide
Victor Bashkirov added a comment -

Item have the data. See on screenshot-3. Before update all working good.

Show
Victor Bashkirov added a comment - Item have the data. See on screenshot-3. Before update all working good.
Hide
Victor Bashkirov added a comment -

Information is added. Please change the status or add comment.

Show
Victor Bashkirov added a comment - Information is added. Please change the status or add comment.
Hide
richlv added a comment -

in the screen, selected period is 07:33-08:33. there are no values in this period (there's only one value per day at 13:54:13)

Show
richlv added a comment - in the screen, selected period is 07:33-08:33. there are no values in this period (there's only one value per day at 13:54:13)
Hide
Victor Bashkirov added a comment -

add screenshot4-5

Show
Victor Bashkirov added a comment - add screenshot4-5
Hide
richlv added a comment -

well, these show that there's no data in screen from 10-17th october, but apparently data for that device stopped coming in at october 9th

Show
richlv added a comment - well, these show that there's no data in screen from 10-17th october, but apparently data for that device stopped coming in at october 9th
Hide
Victor Bashkirov added a comment -

On the screen 5 it is visible that data are for the last 7 days is appear.
Before update all working good.

Show
Victor Bashkirov added a comment - On the screen 5 it is visible that data are for the last 7 days is appear. Before update all working good.
Hide
richlv added a comment -

oh, maybe. but i do not see any bugs there. check the common things - is zabbix server running, is the device reachable etc

Show
richlv added a comment - oh, maybe. but i do not see any bugs there. check the common things - is zabbix server running, is the device reachable etc
Hide
Victor Bashkirov added a comment -

Can you check plain text feature in templates on your zabbix server and provide there working configuration?
and if it works, tell the version of Zabbix

Show
Victor Bashkirov added a comment - Can you check plain text feature in templates on your zabbix server and provide there working configuration? and if it works, tell the version of Zabbix
Hide
Hero Idema added a comment -

The big screen is the host screen from the screen in the template.
Right below is a global test screen, which works.
And to the right above is my latest data.

Show
Hero Idema added a comment - The big screen is the host screen from the screen in the template. Right below is a global test screen, which works. And to the right above is my latest data.
Hide
Hero Idema added a comment -

I don't know if I'm hijacking this. But I have the exact same problem. The "Plain Text" field says "No data defined."
This only occurs if the screen is in a template (the host screen). In a global screen it works fine. It appears that the host screen uses the template-item instead of the host-item. See my screenshot.

Show
Hero Idema added a comment - I don't know if I'm hijacking this. But I have the exact same problem. The "Plain Text" field says "No data defined." This only occurs if the screen is in a template (the host screen). In a global screen it works fine. It appears that the host screen uses the template-item instead of the host-item. See my screenshot.
Hide
Victor Bashkirov added a comment -

This is true that problem has apear on templates screen but on global screen all working fine.

Show
Victor Bashkirov added a comment - This is true that problem has apear on templates screen but on global screen all working fine.
Hide
richlv added a comment - - edited

thanks, confirming with templated screens in trunk rev 30996.

edit : as noted, screen element header also says it's showing data from the template

Show
richlv added a comment - - edited thanks, confirming with templated screens in trunk rev 30996. edit : as noted, screen element header also says it's showing data from the template
Hide
Toms added a comment -

Problem exists when we make a screen with "Plain text" element in template, and then try to see hosts screen in Monitoring > Latest data > click on host name in list > click on "Host screens" on appearing menu. We does not see item data, though we should.

Broken with r29458 ZBXNEXT-1253

Show
Toms added a comment - Problem exists when we make a screen with "Plain text" element in template, and then try to see hosts screen in Monitoring > Latest data > click on host name in list > click on "Host screens" on appearing menu. We does not see item data, though we should. Broken with r29458 ZBXNEXT-1253
Hide
Toms added a comment -

Fixed in dev. branch: svn://svn.zabbix.com/branches/dev/ZBX-5667

Show
Toms added a comment - Fixed in dev. branch: svn://svn.zabbix.com/branches/dev/ZBX-5667
Hide
Victor Bashkirov added a comment -

When it will be added in 2.0.4rc

Show
Victor Bashkirov added a comment - When it will be added in 2.0.4rc
Hide
Eduards Samersovs added a comment -

Tested!

Show
Eduards Samersovs added a comment - Tested!
Hide
Toms added a comment -

Fixed in 2.0.4rc1 r31253, 2.1.0 r31254

Show
Toms added a comment - Fixed in 2.0.4rc1 r31253, 2.1.0 r31254

People

Vote (1)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: