Details

      Description

      during the auto registration of a host with add host to group operation i get a error in the server log:
      1895:20121102:124654.802 [Z3005] query failed: [-1] ORA-06550: line 4, column 1:
      PLS-00103: Encountered the symbol "INSERT" [begin
      insert into hosts_groups (hostgroupid,hostid,groupid) values (271,10217,8);
      end;
      insert into hosts_groups (hostgroupid,hostid,groupid) values (272,10217,14);
      end;
      ]

      the host won´t add to the configured groups
      only the add host operation works and zabbix server adds host to discovered hosts group

        Activity

        Hide
        matthias zeilinger added a comment -

        update:
        it works if i add the host only to one group.
        adding to multiple groups doesn´t work

        Show
        matthias zeilinger added a comment - update: it works if i add the host only to one group. adding to multiple groups doesn´t work
        Hide
        matthias zeilinger added a comment -

        another update:
        it works also if i define 2 seperate autoregistrations.
        one for each host group

        this issue can be set to a lower priority

        Show
        matthias zeilinger added a comment - another update: it works also if i define 2 seperate autoregistrations. one for each host group this issue can be set to a lower priority
        Hide
        Alexander Vladishev added a comment -

        Fixed in the development branch svn://svn.zabbix.com/branches/dev/ZBX-5791

        Show
        Alexander Vladishev added a comment - Fixed in the development branch svn://svn.zabbix.com/branches/dev/ZBX-5791
        Hide
        dimir added a comment -

        Successfully tested! The problem was that transaction was ended inside the loop where insert queries were created. The fix is put transaction-closing tag outside loop.

        Show
        dimir added a comment - Successfully tested! The problem was that transaction was ended inside the loop where insert queries were created. The fix is put transaction-closing tag outside loop.
        Hide
        Alexander Vladishev added a comment -

        Fixed in pre-2.0.4 r31398 and pre-2.1.0 (trunk) r31399.

        Show
        Alexander Vladishev added a comment - Fixed in pre-2.0.4 r31398 and pre-2.1.0 (trunk) r31399.

          People

          • Assignee:
            Unassigned
            Reporter:
            matthias zeilinger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: