Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-620

Js error in IT Services tree

    XMLWordPrintable

Details

    • Incident report
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 1.6
    • 1.6
    • Frontend (F)
    • None

    Description

      http://www.zabbix.com/forum/showthread.php?t=11252

      We have a pretty serious problem with the display of the IT Services in version 1.6.1 (which was probably present in previous version). We are using a IT Services structure that look like this :

      Service 1

      • Sub Service 1 - 1
      • - Sub Service 1 - 1 - 1
      • - Sub Service 1 - 1 - 2
      • Sub Service 1 - 2
      • - Sub Service 1 - 2 - 1
      • - Sub Service 1 - 2 - 2

      Service 2

      • Sub Service 2 - 1
      • Sub Service 2 - 2 (soft link to Service 1)
      • Sub Service 2 - 3 (soft link to Sub Service 3 - 1 - 1)
      • Sub Service 2 - 4 (soft link to Sub Service 3 - 1 - 3)

      Service 3

      • Sub Service 3 - 1
      • - Sub Service 3 - 1 - 1
      • - Sub Service 3 - 1 - 2
      • Sub Service 3 - 2
      • - Sub Service 3 - 2 - 1
      • - Sub Service 3 - 2 - 2

      When we try to expand (with the "+" sign) the "Service 2", either nothing happen or another item from "Service 3" is shown. We can barely edit our IT Services configuration anymore, we found a way but it ain't pretty. Using the "Sort order" to put "Service 2" after "Service 3" seem to make things a little better but we still get some weird behavior with the expand action.

      Neither do we see the soft links under "Service 2"

      Attachments

        Activity

          People

            Unassigned Unassigned
            aly Artem Suharev (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: