ZABBIX BUGS AND ISSUES
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-6315

LLD triggers are deleted immediately if not discovered anymore

    Details

    • Type: Incident report Incident report
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.5
    • Fix Version/s: 2.0.11rc1, 2.2.2rc1, 2.3.0
    • Component/s: Server (S)
    • Labels:
    • Environment:
      Linux, CentOS-6.3, PostgreSQL 9.1.8, Apache HTTPD-2.2.15, PHP-5.3.3

      Description

      We use LLD to dynamically discover ActiveMQ queues. After restarting the application these queues may not exist until they are used the first time. New queues may appear at any time as well as queues may disappear for ever.

      This works quite well for items because they still get their values even if they are no longer discovered and if a queue is no longer available for a reasonable time it gets finally removed from Zabbix.
      In this use case SLA calculation gets broken if it depends on triggers which are based on LLD prototypes.

      Not sure if it's a bug or the documentation doesn't point it out clearly:
      "Items (similarly, triggers and graphs) created by a low-level discovery rule [...] will be deleted automatically if a discovered entity [...] stops being discovered [...] they will be deleted after the days defined in the Keep lost resources period field pass."

      That's exactly how it works for items but not for triggers.
      Triggers based on LLD prototypes are deleted immediately if not discovered anymore. Normally that wouldn't have a big impact because they get created again as soon as they will re-discovered. But this behavior is really counterproductive if one got hundreds of LLD-Triggers that are used for SLA calculations in IT-Services.

        Issue Links

          Activity

          Oleksiy Zagorskyi added a comment -

          Interesting, need to check.

          This works quite well for items because they still get their values even if they are no longer discovered ...

          ZBX-4475 - related to the quote

          Mark Strey added a comment -

          are there any Plans to fix this in 2.0.6? It´s critical for our Environment where nearly everything will be discovered dynamically...

          Riaan Olivier added a comment -

          Can we please have an update on this task. Would love this to be fixed in the next version. Agree with mark Strey above, we also setup almost all our our monitoring as automated discoveries and would like this fixed. We are missing services thats down because the auto discovery removes the triggers.

          richlv added a comment -

          this is not on the roadmap currently

          Marc added a comment -

          In this case the documentation should be corrected

          adient added a comment -

          Any update on getting this on the roadmap? Completely breaks monitoring we've designed to use the low-level discovery feature.

          Volker Fröhlich added a comment -

          I tripped over that as well! Please update the documentation!

          Raymond Kuiper added a comment -

          I've run into issues here as well. Some types of item/trigger combinations need to stay active for a while, even if LLD has not discovered them on the last run.
          Would be nice to state a grace period in the discovery in addition to the cleanup period ("Keep lost resources period (in days)").

          Andrey Semyonov added a comment - - edited

          As of ZBX-6914 I could provide some scenarios either: dynamic SNMP tables monitored with LLD, for example OSPF-MIB::ospfNbrTable.

          As for suggestions: trigger prototypes and triggers based on them could be flagged as "keep within related items' keep in history interval", so at least configuration manager (or zbx-admin) makes his own decision on whether he needs trigger persistence or better not.

          Andrey Semyonov added a comment -

          Furthermore, some related bugs refer to ZBXNEXT-1575 as for trigger states upon item's availability states. If so, then this might be a blocker bug for 2.2

          Andrey Semyonov added a comment -

          I've proposed a very rough patch here: https://support.zabbix.com/secure/attachment/23912/lld-c.patch

          If anyone could review the patch and could also make appropriate changes to frontend that'd be a great start to fix this issue.

          richlv added a comment - - edited

          (1) when this is fixed, it should be checked that graphs are kept for that period, too

          <richlv> graphs are ZBX-5789 , CLOSED

          zhangjialiang added a comment - - edited

          Any update about this issue? We can not try zabbix 2.2.0, the bug will make our lld-related check useless.

          Marc added a comment -

          Just become aware about an actually obvious fact of loosing related events as well

          Alexander Vladishev added a comment -

          It will be fixed with ZBX-7109. LLD trigger-related code will completely rewritten.

          Please wait a little.

          richlv added a comment -

          closing as a dupe of ZBX-7109 where this was fixed

          richlv added a comment -

          ...actually, not fixed yet, reopening

          yuusou added a comment -

          This is still happening with 2.2.1. Also, deleting the host and re-adding it by hand doesn't re-create the triggers nor graphs. I have identical hardware and software (bar IPs and hostnames) with completely different number of triggers and graphs between them. I use solely SNMP.

          Alexander Vladishev added a comment - - edited

          Fixed in pre-2.0.11 r41917, pre-2.2.2 r41993 and pre-2.3.0 r42023.


            People

            • Assignee:
              Unassigned
              Reporter:
              Marc
            • Votes:
              19 Vote for this issue
              Watchers:
              26 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: