Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-7526

Undefined offset on maps with links and Host groups with Host group elements shown

    XMLWordPrintable

    Details

    • Type: Incident report
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.2.1
    • Fix Version/s: None
    • Component/s: Frontend (F)
    • Labels:
      None

      Description

      Hello

      After upgrade from Zabbix 2.0.9 to 2.2.1 we have errors on our maps.

      When we have on some linked elements and host group on maps, Undefined offset errors are shown:

      Undefined offset: 100100000001013 [maps.php:148 ? CView->render() ? include() ? getActionMapBySysmap() ? populateFromMapAreas() in /usr/share/zabbix/include/maps.inc.php:2107]
      Undefined offset: 100100000001013 [maps.php:148 ? CView->render() ? include() ? getActionMapBySysmap() ? populateFromMapAreas() in /usr/share/zabbix/include/maps.inc.php:2107]
      Undefined offset: 100100000000993 [maps.php:148 ? CView->render() ? include() ? getActionMapBySysmap() ? populateFromMapAreas() in /usr/share/zabbix/include/maps.inc.php:2107]
      Undefined offset: 100100000001026 [maps.php:148 ? CView->render() ? include() ? getActionMapBySysmap() ? populateFromMapAreas() in /usr/share/zabbix/include/maps.inc.php:2107]
      Undefined offset: 100100000001013 [maps.php:148 ? CView->render() ? include() ? getActionMapBySysmap() ? populateFromMapAreas() in /usr/share/zabbix/include/maps.inc.php:2107]
      Undefined offset: 100100000001013 [maps.php:148 ? CView->render() ? include() ? getActionMapBySysmap() ? populateFromMapAreas() in /usr/share/zabbix/include/maps.inc.php:2107]
      Undefined offset: 100100000000993 [maps.php:148 ? CView->render() ? include() ? getActionMapBySysmap() ? populateFromMapAreas() in /usr/share/zabbix/include/maps.inc.php:2107]
      

      When we have linked elements without any host group on map everything is ok.
      When we don't have any linked elements and host group on map everything is also ok.

      What can we do with this error?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              kpucynski Karol Pucynski
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: