Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-7819

Importing XML template has strange behavior when there are comments

    XMLWordPrintable

    Details

    • Type: Incident report
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.0, 2.2.1
    • Fix Version/s: None
    • Component/s: Frontend (F)
    • Labels:
    • Environment:
      Centos 6.5. All packages installed via yum repo

      Description

      WHen trying to import this template, multiple issues occur: https://raw2.github.com/htaira/glubix/master/templates/Template_App_Gluster.xml

      1) The import reports successfull even though it is not successful
      2) If I remove the XML comments from the file and try to import, then it fails to import with an error: "Incorrect arguments passed to function."
      3) It seems like there are problems when importing as host because it succeeds even though there are no interfaces defined (Richlv and volter discovered this and have more info about it)

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              zabbix.dev Zabbix Development Team
              Reporter:
              macwinner Amit Aggarwal
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: