Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-8071

Monitoring -> Latest data => undefined index

    XMLWordPrintable

Details

    • Incident report
    • Resolution: Duplicate
    • Minor
    • None
    • 2.2.3
    • Frontend (F)

    Description

      I noticed that in footer of page 'Monitoring' -> 'Latest data' for one host appeared errors:

      Undefined offset: 984 [ in /usr/share/zabbix/latest.php:518]
      Undefined index: item_cnt [ in /usr/share/zabbix/latest.php:518]
      Undefined index: hostid [ in /usr/share/zabbix/latest.php:527]
      Undefined index:  [ in /usr/share/zabbix/latest.php:527]
      Undefined index: applicationid [ in /usr/share/zabbix/latest.php:533]
      Undefined index: applicationid [ in /usr/share/zabbix/latest.php:539]
      Undefined index: applicationid [ in /usr/share/zabbix/latest.php:554]
      Undefined index: name [ in /usr/share/zabbix/latest.php:557]
      Undefined index: applicationid [ in /usr/share/zabbix/latest.php:564]
      Undefined index: applicationid [ in /usr/share/zabbix/latest.php:564]
      Undefined index: applicationid [ in /usr/share/zabbix/latest.php:564]
      

      Probably my problem connected with my template for web monitoring ('Template HTTP check snypir.com', which contains one web-check for substring on site and one trigger which indicate problem if substring not found). This template assigned to two hosts (lb-2 and lb-3).

      For host lb-2 in 'Latest data' I see 6 items (see screenshot named 'OK'):

      Download speed for scenario "Substring on front page".
      Download speed for step "get_snypir.com_/" of scenario "Substring on front page".
      Failed step of scenario "Substring on front page".
      Last error message of scenario "Substring on front page".
      Response code for step "get_snypir.com_/" of scenario "Substring on front page".
      Response time for step "get_snypir.com_/" of scenario "Substring on front page".
      

      For host lb-3 in 'Latest data' I see only 3 items from my template and 3 items hidden in ''. But I can't expand '' symbol. For this case please see screenshot named 'problem'.

      Just FYI: I didn't edit database manually or makes any undocumented things.

      Attachments

        1. OK.png
          OK.png
          70 kB
        2. problem.png
          problem.png
          68 kB

        Issue Links

          Activity

            People

              Unassigned Unassigned
              umask00 Ilyas
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: