Details

      Description

      When I try to export any map the XML file contains (only) the following error message:

      [error] Undefined index: sysmapid [sysmaps.php:112 → CConfigurationExport->export() → CConfigurationExport->gatherData() → CConfigurationExport->gatherMaps() → CFrontendApiWrapper->get() → CApiWrapper->__call() → CFrontendApiWrapper->callMethod() → CApiWrapper->callMethod() → CFrontendApiWrapper->callClientMethod() → CLocalApiClient->callMethod() → call_user_func_array() → CMap->get() → CMap->addRelatedObjects() → CApiService->createRelationMap() in /var/www/zabbix/include/classes/api/CApiService.php:327]
      

        Issue Links

          Activity

          Hide
          richlv added a comment -

          i'm getting the same, but only for a certain map that references other map. i have not tracked it down yet or reproduced with a map, created from the scratch. have you been able to do that ?

          Show
          richlv added a comment - i'm getting the same, but only for a certain map that references other map. i have not tracked it down yet or reproduced with a map, created from the scratch. have you been able to do that ?
          Hide
          Jens Berthold added a comment - - edited

          I tried it now from scratch: when I create a new map, everything is fine.
          As soon as I assign an "Automatic icon mapping" the error occurs.
          Maybe you can change to issue title to "... with automatic icon mapping".

          Show
          Jens Berthold added a comment - - edited I tried it now from scratch: when I create a new map, everything is fine. As soon as I assign an "Automatic icon mapping" the error occurs. Maybe you can change to issue title to "... with automatic icon mapping".
          Hide
          richlv added a comment -

          indeed, i can confirm that - thanks for figuring it out

          Show
          richlv added a comment - indeed, i can confirm that - thanks for figuring it out
          Hide
          richlv added a comment -

          for the record, just selecting icon mapping for the map is enough, it is not needed to use it on any element for the problem to appear

          Show
          richlv added a comment - for the record, just selecting icon mapping for the map is enough, it is not needed to use it on any element for the problem to appear
          Hide
          Oleg Egorov added a comment - - edited

          (1) Related issue ZBX-8994

          Ivo Kurzemnieks Provided fix also fixes this issue. Good work!

          CLOSED.

          Show
          Oleg Egorov added a comment - - edited (1) Related issue ZBX-8994 Ivo Kurzemnieks Provided fix also fixes this issue. Good work! CLOSED.
          Hide
          Oleg Egorov added a comment -

          RESOLVED IN svn://svn.zabbix.com/branches/dev/ZBX-8950 r50510

          Show
          Oleg Egorov added a comment - RESOLVED IN svn://svn.zabbix.com/branches/dev/ZBX-8950 r50510
          Hide
          Oleg Egorov added a comment - - edited

          (2) No string changes.

          Ivo Kurzemnieks CLOSED.

          Show
          Oleg Egorov added a comment - - edited (2) No string changes. Ivo Kurzemnieks CLOSED.
          Hide
          Ivo Kurzemnieks added a comment - - edited

          (3) Using "selectIconMap" option, "iconmapid" is now mandatory for "output".

          Ivo Kurzemnieks I fixed the issue in r51245, r51257 please review.

          Oleg Egorov Very good improvement! CLOSED

          Show
          Ivo Kurzemnieks added a comment - - edited (3) Using "selectIconMap" option, "iconmapid" is now mandatory for "output". Ivo Kurzemnieks I fixed the issue in r51245, r51257 please review. Oleg Egorov Very good improvement! CLOSED
          Hide
          Ivo Kurzemnieks added a comment -

          TESTED,

          but review and close (3) before merging.

          Show
          Ivo Kurzemnieks added a comment - TESTED, but review and close (3) before merging.
          Hide
          Oleg Egorov added a comment -

          FIXED IN 2.4.4rc1 r51262 and 2.5.0(trunk) r51263

          Show
          Oleg Egorov added a comment - FIXED IN 2.4.4rc1 r51262 and 2.5.0(trunk) r51263
          Show
          Oleg Egorov added a comment - Documented: https://www.zabbix.com/documentation/2.4/manual/api/changes_2.2_-_2.4?&#map

            People

            • Assignee:
              Unassigned
              Reporter:
              Jens Berthold
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: