Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-8964

SNMP agent item failed: first network error, wait for 15 seconds

    XMLWordPrintable

Details

    • Incident report
    • Resolution: Duplicate
    • Trivial
    • None
    • 2.4.1
    • Proxy (P)
    • None
    • Oracle Linux 6.6 x86_64 VM, zabbix_proxy 2.4.1 + sqlite3

    Description

      I have distributed monitoring that using proxies for check devices on client-side.

      Some of my proxies generates alot of errors:
      1857:20141028:105659.890 SNMP agent item "IfHCOutOctets[FastEthernet0/21]" on host "rostovdon-1-sw1" failed: first network error, wait for 15 seconds
      1799:20141028:105705.803 SNMP agent item "ifHCInOctets[FastEthernet0/20]" on host "izjevsk-1-sw1" failed: first network error, wait for 15 seconds
      2502:20141028:105708.190 resuming SNMP agent checks on host "volgograd-1-sw1": connection restored
      1910:20141028:105708.847 SNMP agent item "locIfInRunts[Vlan100]" on host "samara-1-sw1" failed: first network error, wait for 15 seconds
      2266:20141028:105709.161 SNMP agent item "locIfCollisions[FastEthernet0/32]" on host "ho-1-sw2" failed: first network error, wait for 15 seconds
      1765:20141028:105711.973 SNMP agent item "locIfInIgnored[GigabitEthernet0/3]" on host "ho-1-sw3" failed: first network error, wait for 15 seconds
      2502:20141028:105714.215 resuming SNMP agent checks on host "rostovdon-1-sw1": connection restored
      1706:20141028:105715.072 SNMP agent item "IfHCOutOctets[FastEthernet0/43]" on host "ho-1-sw4" failed: first network error, wait for 15 seconds
      2348:20141028:105718.883 SNMP agent item "ifAdminStatus[FastEthernet0/18]" on host "lipeck-1-sw1" failed: first network error, wait for 15 seconds
      1705:20141028:105719.233 SNMP agent item "locIfInRunts[GigabitEthernet2/0/6]" on host "n.novgorod-cc-c3750" failed: first network error, wait for 15 seconds
      2502:20141028:105720.238 resuming SNMP agent checks on host "izjevsk-1-sw1": connection restored
      1639:20141028:105721.030 SNMP agent item "locIfInCRC[FastEthernet0/20]" on host "n.novgorod-cc-sw1" failed: first network error, wait for 15 seconds
      2502:20141028:105723.339 resuming SNMP agent checks on host "samara-1-sw1": connection restored
      1760:20141028:105723.698 SNMP agent item "ifHCInOctets[Vlan20]" on host "stavropol-1-sw1" failed: first network error, wait for 15 seconds
      2502:20141028:105724.348 resuming SNMP agent checks on host "ho-1-sw2": connection restored
      2425:20141028:105725.493 SNMP agent item "ifInErrors[FastEthernet0/12]" on host "n.novgorod-cc-sw3" failed: first network error, wait for 15 seconds
      2502:20141028:105726.356 resuming SNMP agent checks on host "ho-1-sw3": connection restored
      1915:20141028:105727.808 SNMP agent item "ifOutErrors[Vlan1]" on host "n.novgorod-cc-sw4" failed: first network error, wait for 15 seconds
      1999:20141028:105728.901 SNMP agent item "locIfInFrame[FastEthernet0/2]" on host "tula-1-sw1" failed: first network error, wait for 15 seconds
      2502:20141028:105730.374 resuming SNMP agent checks on host "ho-1-sw4": connection restored
      2502:20141028:105733.387 resuming SNMP agent checks on host "lipeck-1-sw1": connection restored
      2502:20141028:105734.398 resuming SNMP agent checks on host "n.novgorod-cc-c3750": connection restored

      and looks like some of items don't recieved for a long time (bcause queue proxy queue for a day). this is only snmp item problem.

      anyway. i try to get those items by snmpget/snmpwalk In loop and doesnt have any problem.

      also i have tried many variations:
      oracle linux 6.6 + zabbix_proxy 2.4.1 + vmware-tools drivers(vmxnet3) + esxi 5.1
      oracle linux 6.6 + zabbix_proxy 2.4.1 + linux embeded drivers(vmxnet3) + esxi 5.1
      oracle linux 6.6 + zabbix_proxy 2.4.1 + vmware-tools drivers(vmxnet3) + esxi 5.5
      oracle linux 6.6 + zabbix_proxy 2.4.1 + linux embeded drivers(vmxnet3) + esxi 5.5
      ubuntu 14.04 LTS + zabbix_proxy 2.4.1 + vmware-tools drivers(vmxnet3) + esxi 5.1
      ubuntu 14.04 LTS + zabbix_proxy 2.4.1 + linux embeded drivers(vmxnet3) + esxi 5.1

      and right now i trying to test on hardware server..

      what kind of problem this can be ?

      Attachments

        1. zbx_export_cisco_switch_template.xml
          102 kB
        2. zab.miss.data.PNG
          zab.miss.data.PNG
          25 kB
        3. suschevka-1-sw2-after-restart-proxy.pcap
          1.03 MB
        4. suschevka-1-sw2.pcap
          1.37 MB
        5. snmp-check.png
          snmp-check.png
          13 kB
        6. no-retry-screenshot.png
          no-retry-screenshot.png
          96 kB
        7. chart2 (1).png
          chart2 (1).png
          82 kB

        Issue Links

          Activity

            People

              Unassigned Unassigned
              xocolate Arthur Ivanov
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: