Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-8980

SNMP item with dynamic indexes fail: "cannot find index..." #2

    XMLWordPrintable

Details

    • Incident report
    • Resolution: Duplicate
    • Minor
    • None
    • 2.4.1
    • Server (S)
    • FreeBSD 10.0-RELEASE
      net-snmp-5.7.2_16

    Description

      I have SNMP items with dynamic indexes in Zabbix 2.4.1 after upgrade from 2.2.6:

      SNMP OID:

      ENTITY-MIB::entPhysicalSerialNum["index","ENTITY-MIB::entPhysicalClass","3"]
      
      zabbix:/home/DOMAIN/kbp% snmpwalk -v2c -c public 192.168.20.114 ENTITY-MIB::entPhysicalClass
      ENTITY-MIB::entPhysicalClass.1 = INTEGER: stack(11)
      ENTITY-MIB::entPhysicalClass.1001 = INTEGER: chassis(3)
      ENTITY-MIB::entPhysicalClass.1002 = INTEGER: module(9)
      ...
      

      The searching index is 1001.

      zabbix:/home/DOMAIN/kbp% snmpwalk -v2c -c public 192.168.20.114 ENTITY-MIB::entPhysicalSerialNum.1001
      ENTITY-MIB::entPhysicalSerialNum.1001 = STRING: CAT1012R1XK
      

      It's OK.

      But Zabbix generates an error:

      8713:20141101:140211.653 error reason for "sw-catalyst:entPhysicalSerialNum" changed: Cannot find index of "3" in "ENTITY-MIB::entPhysicalClass".
      

      ZBX-4793
      https://www.zabbix.com/forum/showthread.php?t=46775

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              drtr0jan Boris P. Korzun
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: