Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-9037

RHEL 6 package requires java 8

    XMLWordPrintable

Details

    • Incident report
    • Status: Closed
    • Critical
    • Resolution: Fixed
    • 2.4.2
    • 2.0.14, 2.2.8, 2.4.3
    • Java gateway (J)
    • None
    • RHEL 6

    Description

      zabbix-java-gateway-2.4.1 package from the Zabbix repository requires java 6 (its class file has major version 50).

      When upgrading to zabbix-java-gateway-2.4.2, the class file is compiled with major version 52, which implies that it requires java 8.

      We can't upgrade java to version 8 on production machines yet which implies that we have to keep running zabbix-java-gateway-2.4.1.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              dlazaro David Lazaro
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: