Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 2.4.2
    • Fix Version/s: None
    • Component/s: Frontend (F)
    • Labels:
    • Environment:
      Zabbix installed from packages.

      Description

      When Next is clicked on the pre-requisites page, it returns back to the initial greeting page and does not go on to "Configure DB connection" page. Prereqs are all green. How to reproduce:
      1) set "Group zabbix" instead "Group apache" in httpd.conf
      2) restart apache
      3) open frontend configuration wizard
      4) try to finish frontend configuration by clicking next -> next -> next.

        Activity

        Alexander Vladishev added a comment -

        Not reproducible on latest 2.2.

        Oleg Ivanivskyi added a comment -

        The permissions were the reason (example for CentOS):

        ls -l /var/lib/php
        drwxrwx--- 2 root apache 4096 Nov 24 15:20 session

        If I need to change the user group, I must correct permissions to the session folder also.
        I believe, it's a good idea to add this note to the documentation.

        Krists Krigers added a comment -

        The issue was caused by Apache not being able to read session file due to change of user group it is running under while setup.php was being used.

        Problem did not exist in 2.2 as then intermediate data was stored in a cookie (yes, indeed), and not in session storage (which is files by default).

        It might be a a good idea to add some message explaining this behavior in documentation - e.g. if user or group used by Apache web-server is changed, permissions to session files should be verified to be accessible.

        Nuno Rodrigues added a comment -

        Apparently this same issue can have a different cause. I'm using Ubuntu 14.04.01 LTS (server). After trying every "tricks" I could remember, without success, I decided to start tweaking php.ini session parameters one by one.

        I found that when you have changed "session.name = PHPSESSID" to "session.name = SOMETHINGELSE" you will have this same problem.

        richlv added a comment -

        for the record, i could not reproduce the problem with session.name in php 5.5.8


          People

          • Assignee:
            Unassigned
            Reporter:
            Oleg Ivanivskyi
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: