Details

    • Type: Incident report Incident report
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.4.3
    • Fix Version/s: 2.4.4rc1, 2.5.0
    • Component/s: Agent (G)
    • Environment:
      Arch linux; Linux hostname 3.18.1.201501042021-1-grsec #1 SMP PREEMPT Mon Jan 5 09:44:10 EST 2015 x86_64 GNU/Linux

      Description

      I have a template, with 1 app and 1 item:
      net.tcp.service[https] (zabbix agent active)
      As soon as I link my host with that template, zabbix agentd crashes. Full log and config attached.
      I don't understand why, since the host is linked with another template that contains "net.tcp.service[ssh]" that works just fine. Also, I don't understand why in the log zabbix agentd complains that the https check is not supported prior to crashing.
      Note grsec has nothing to do with it, it crashes on vanilla kernel also.

      1. crash.txt
        11 kB
        michal svoboda
      2. objdump.txt.bz2
        893 kB
        michal svoboda
      3. zabbix_agentd.conf
        0.1 kB
        michal svoboda

        Issue Links

          Activity

          Hide
          Aleksandrs Saveljevs added a comment -

          Indeed, it seems to crash after "net.tcp.service[https]" check is processed if agent is compiled without cURL support.

          Meanwhile, you might wish to compile the agent with cURL by passing "--with-libcurl" option to ./configure.

          Show
          Aleksandrs Saveljevs added a comment - Indeed, it seems to crash after "net.tcp.service[https]" check is processed if agent is compiled without cURL support. Meanwhile, you might wish to compile the agent with cURL by passing "--with-libcurl" option to ./configure.
          Hide
          Aleksandrs Saveljevs added a comment -

          Seems to work well in the latest 2.2.

          Show
          Aleksandrs Saveljevs added a comment - Seems to work well in the latest 2.2.
          Hide
          Aleksandrs Saveljevs added a comment -

          Fixed in development branch svn://svn.zabbix.com/branches/dev/ZBX-9206 .

          Show
          Aleksandrs Saveljevs added a comment - Fixed in development branch svn://svn.zabbix.com/branches/dev/ZBX-9206 .
          Hide
          Aleksandrs Saveljevs added a comment -

          The problem was that the error message was not set in the following cases:

          • net.tcp.service[ldap] is used and agent compiled without LDAP support;
          • net.tcp.service[https] is used and agent compiled without cURL support;
          • net.tcp.service[] used with a bad first argument.

          If these checks were used as active agent checks, then the agent would try to use the error message and would crash.

          Show
          Aleksandrs Saveljevs added a comment - The problem was that the error message was not set in the following cases: net.tcp.service[ldap] is used and agent compiled without LDAP support; net.tcp.service[https] is used and agent compiled without cURL support; net.tcp.service[] used with a bad first argument. If these checks were used as active agent checks, then the agent would try to use the error message and would crash.
          Hide
          Aleksandrs Saveljevs added a comment -

          Fixed in pre-2.4.4 r51532 and pre-2.5.0 (trunk) r51533.

          Show
          Aleksandrs Saveljevs added a comment - Fixed in pre-2.4.4 r51532 and pre-2.5.0 (trunk) r51533.

            People

            • Assignee:
              Unassigned
              Reporter:
              michal svoboda
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: