Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-9908

maintenance.update API requires active_since parameter

    Details

    • Type: Incident report
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.2.10
    • Fix Version/s: None
    • Component/s: API (A)
    • Labels:
      None

      Description

      Accorting to documentation, maintenance.update can replace hosts or hostgroups.
      https://www.zabbix.com/documentation/2.2/manual/api/reference/maintenance/update

      The API request same as the documentation above fails with this error

      {"message": "Invalid params.", "code": -32602, "data": "\\"Active since\\" must be between 1970.01.01 and 2038.01.18."}
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                kodai Kodai Terashima
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: