ZABBIX FEATURE REQUESTS

Flicker-free screen shading after two failed updates.

Details

  • Type: Sub-task Sub-task
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 2.0.0
  • Fix Version/s: 2.0.4, 2.1.0
  • Component/s: Frontend (F)
  • Labels:
  • Zabbix ID:
    NMR

Activity

Eduards Samersovs added a comment -

Implemented in development branch svn://svn.zabbix.com/branches/dev/ZBXNEXT-1398

Alexey Fukalov added a comment - - edited

(1)
If Screen element update time is greater than refresh interval it seems it's shadowed only once.

Set interval 10sec, refresh timeout 1sec and sleep(15) in map.php for example.

Eduards Samersovs RESOLVED

Alexey Fukalov seems still reproducible

Eduards Samersovs RESOLVED

Alexey Fukalov CLOSED

Alexey Fukalov added a comment - - edited

(2)
Not sure if it's connected to this issue, but on our default screen with map and 2 graphs i cannot use zoom on second graph.

<Eduard> Yes, it's already reported in ZBX-5578 (2)

Alexey Fukalov CLOSED

Alexey Fukalov added a comment - - edited

(3)
1. have some element with long loading time (sleep(5)) and refresh timeout 1 sec.
2. move timeline bar on screen, element is shadowed.
3. while it's shadowed move timeline again.
4. when element is loaded (no shadow), move timeline again, this time element is not shadowed.

Eduards Samersovs RESOLVED

Alexey Fukalov CLOSED

Alexey Fukalov added a comment - - edited

(4)
Vertical text doesn't work in Firefox 15.0.1 in Windows 7 64bit

Eduards Samersovs RESOLVED, Seems vendor prefix -moz still needed

Alexey Fukalov CLOSED

richlv added a comment - - edited

(5) i'm concerned that a jquery plugin was added in this issue, but it was never mentioned in svn commit messages. shouldn't we document (somewhere) what other software is includes ?

Eduards Samersovs RESOLVED, see http://zabbix.org/wiki/Docs/specs/ZBXNEXT-1398#Specification

<richlv> looking good for this issue, but it mentions two new configuration parameters. where are they exposed to user ? defines.inc.php ?

Eduards Samersovs Yes, all our parameters are stored in one file..

<richlv> then they should be documented in http://www.zabbix.com/documentation/2.0/manual/web_interface/definitions
that should mention from which version they are available, and also should be done for 2.2 docs

Eduards Samersovs RESOLVED

<richlv> doesn't mention the version from which they will be available (2.0.4, i assume)
as for params, SCREEN_REFRESH_TIMEOUT is just that - if we haven't been able to update an element for n seconds, it will be darkened, right ?
SCREEN_REFRESH_RESPONSIVENESS is a bit unclear still - what's the purpose of it ?

Eduards Samersovs SCREEN_REFRESH_TIMEOUT yes you understand right. SCREEN_REFRESH_RESPONSIVENESS is useful for example in second use case:
Update interval is 5 minutes. SCREEN_REFRESH_RESPONSIVENESS is 10 seconds. Server/browser built-in timeout (for example) is 10 minutes. User click on screen for update. Request is sending. Server is crashed at this time and don't send response. Browser just wait.. Any user clicking after what will be ignored until response will be received. So we will wait until next update planing time (5 minutes) will happens. But! SCREEN_REFRESH_RESPONSIVENESS defines time after witch user click will generate new request and define new time point after witch next clicking will be ignored. So, maybe at this time server will be live and response will be received. If server finally reacts on first request and send response - it will be validated on timestamps and will be ignored if second request get a latest data. So, without SCREEN_REFRESH_RESPONSIVENESS user can wait 5 minutes to get a data, but with this param user will wait only 10 seconds + request/response time.

<richlv> ok, one last thing...
what does "User click on screen for update" include ? changing time period ? anything else ?

Eduards Samersovs May say any user action witch lead to data update..

<richlv> but i have a hard time imagining other user action than changing the time period - what else could there be ? (in screens)

Eduards Samersovs Rich, do you want a list with possible user action witch leads to screen updates? Read documentation or ask documentors. For this task main goal is process update action and that has served for this action is not important! Sorry I don't understand you idea..

Alexey Fukalov added a comment - - edited

(6)
Let's move activity-indicator lib to /vendors/ subdir.

Eduards Samersovs RESOLVED

Alexey Fukalov CLOSED

Alexey Fukalov added a comment - - edited

(7)
When window size is changed during active shadowing, loading indicator position is not recalculated.

Eduards Samersovs RESOLVED

Alexey Fukalov CLOSED

Alexey Fukalov added a comment - - edited

(8)
Triggers overview element on screen gets shadowed even if there are no delay.

Eduards Samersovs RESOLVED

Alexey Fukalov CLOSED

Alexander Vladishev added a comment - - edited

(9) frontend generates large quantity of requests if web server isn't accessible

Eduards Samersovs RESOLVED
Alexander Vladishev CLOSED

Alexander Vladishev added a comment - - edited

(10) the zone of shading comes out of limits of a graph in Monitoring->Graphs and Monitoring->Latest Data screens

Eduards Samersovs RESOLVED

Alexander Vladishev CLOSED

Alexander Vladishev added a comment - - edited

(11) after shading, the first successful refresh shows graph incorrectly in Monitoring->Graphs and Monitoring->Latest Data screen.

Eduards Samersovs RESOLVED

Alexander Vladishev CLOSED

Alexander Vladishev added a comment - - edited

(12) slides refresh don't work

Eduards Samersovs RESOLVED

Alexander Vladishev REOPENED Timeline shows predefined filters multiple times after slide change
Error has occured:
Uncaught TypeError: Cannot read property 'timestamp' of undefined jsLoader.php:3667
window.flickerfreeScreenShadow.end jsLoader.php:3667
(anonymous function) jsLoader.php:3535
f.event.dispatch jsLoader.php:4979
h.handle.i

Alexander Vladishev CLOSED

Alexander Vladishev added a comment - - edited

(13) SCREEN_REFRESH_RESPONSIVENESS doesn't affect a timeline

Eduards Samersovs RESOLVED

Alexander Vladishev CLOSED

Alexey Fukalov added a comment - - edited

(14)
Timeline is not updated in slides.

Eduards Samersovs RESOLVED

Alexander Vladishev CLOSED See (12)

Alexey Fukalov added a comment - - edited

(15)
Seems introduced in this branch.
Logout from frontend, in logint form there is error 'Empty parameter'.

Eduards Samersovs RESOLVED. Dev branch was recreated with latest source from 2.0.

Alexey Fukalov CLOSED

Eduards Samersovs added a comment -

ATTENTION! Implemented in development branch svn://svn.zabbix.com/branches/dev/ZBXNEXT-1398-2

Alexander Vladishev added a comment - - edited

(16) Shading don't work with an update interval 10 sec.

Eduards Samersovs RESOLVED

Alexander Vladishev CLOSED

Alexander Vladishev added a comment - - edited

(17) Simple graphs don't remember the last selected period

Eduards Samersovs RESOLVED

<Sasha> CLOSED

Toms added a comment - - edited

(18) In IE9 Monitoring > Overview host names are upside down

Eduards Samersovs Unfortunately I don't have solution how to fix this problem, in IE8 it work correct!

Alexey Fukalov I managed to get it work in ie9:

  • remove 'writing-mode' and add '-ms-transform: rotate(270deg);' css properties in default.css.
  • add '-ms-transform-origin": transform' in class.ctableinfo.php

Eduards Samersovs RESOLVED r30910

Alexey Fukalov CLOSED

  • remove 'writing-mode' and add '-ms-transform: rotate(270deg);' css properties in default.css.
  • add '-ms-transform-origin": transform' in class.ctableinfo.php
Eduards Samersovs RESOLVED r30910 Alexey Fukalov CLOSED
Toms added a comment - - edited

(19) Monitoring > Overview vertical host names are quite unreadable in Chrome and IE9, other fonts should be considered.

Eduards Samersovs RESOLVED

<richlv> this is a perfect chance to mention the used fix in the issue comment here

Eduards Samersovs Yes, font was changes from Verdana to Arial and size from 10px to 11px.
Rich but, you need to spend some time to meditate on a subject where is that boundary between source code and documentation. Because I feel inside yourself you want from developer to explain every source code line from the diff.. =)))

<richlv> no, this is a very basic part of working as a team, and as a one exposed to the community a lot. ability to describe what one has done is not just helpful for the community, it is very helpful for the resulting product as well. if we take this specific example, mentioning changes in public has a chance of somebody spotting an issue (maybe a specific font family should be avoided for some reasons), and it also works as at least some sort of a technical design document seed. nobody knows how overview should operate in detail. if we add more unknowns (which font/family is it supposed to use ? which font size ?), we make life harder for users, other developers, testers - well, everybody.

we are not working in isolation. let's learn to communicate, it is an essential skill.

Toms CLOSED

Eduards Samersovs added a comment -

Eduards Samersovs I agree with you, but this a mostly documentation field. Yes, we need more structural documentation cell (section) for the such technical issues. Hmm, I think we need documentation + specification + manual + tutorial.. keep in one page to see all at once!

Alexey Fukalov added a comment - - edited

(20)
Add Status of zabbix element to screen.
Element has hints with links to event acknowledges.
Try to acknowledge event.

Eduards Samersovs RESOLVED, r30911 =))

Alexey Fukalov CLOSED

Pavels Jelisejevs added a comment - - edited

(21) Here's a tricky problem. I have SCREEN_REFRESH_TIMEOUT set to 10s, update interval - 10s and a delay of 10s. This means, that screen elements must always be displayed normally, except for, may be, some flickering due to additional delays. But they are always darkened.

Alexey Fukalov For me if i have sleep(15) for graph, 10sec timeout and refresh less than 6 sec, simple graphs are not shadowed at all.
Eduards Samersovs Vedmak, specially your event is fixed! r30915

Eduards Samersovs After discussion with Sasha decided that current shadowing implementation is ok.

Pavels Jelisejevs added a comment - - edited

(22) When the delay is high enough so that an element should always be shadowed, some elements like plain text flicker when new data arrives.

Eduards Samersovs RESOLVED

Pavels Jelisejevs CLOSED.

Eduards Samersovs added a comment -

Fixed in versions pre-2.1.0 (beta) r30977, pre-2.0.4 r30971

richlv added a comment -

this resulted in a regression : ZBX-7553

richlv added a comment -

this issue also changed vertical text in monitoring -> overview from rendered images to vtext, but this was not mentioned in the changelog - that's ZBX-6311


People

Vote (0)
Watch (2)

Dates

  • Created:
    Updated:
    Resolved: