ZABBIX FEATURE REQUESTS
  1. ZABBIX FEATURE REQUESTS
  2. ZBXNEXT-2069

Support of {HOST.PORT} macro in the notifications

    Details

      Description

      Now

      {HOST.PORT}

      macro is supported by auto-registration notifications.

      The functionality should be extended. This macro should be supported by trigger-based and internal notifications as well.

        Activity

        Show
        Andris Zeila added a comment - Documentation update: https://www.zabbix.com/documentation/2.2/manual/appendix/macros/supported_by_location?&#overview https://www.zabbix.com/documentation/2.2/manual/introduction/whatsnew222?&#daemon_improvements Not sure if Daemon Improvements was the best place for whatsnew note.
        Hide
        Andris Zeila added a comment -

        Fixed in development branch svn://svn.zabbix.com/branches/dev/ZBXNEXT-2069

        Show
        Andris Zeila added a comment - Fixed in development branch svn://svn.zabbix.com/branches/dev/ZBXNEXT-2069
        Hide
        Aleksandrs Saveljevs added a comment -

        Tested. Looks wonderful.

        Show
        Aleksandrs Saveljevs added a comment - Tested. Looks wonderful.
        Hide
        Andris Zeila added a comment -

        Released in:
        pre-2.2.2rc1 r40967
        pre-2.3.0 r40968

        Show
        Andris Zeila added a comment - Released in: pre-2.2.2rc1 r40967 pre-2.3.0 r40968
        Hide
        Andris Zeila added a comment - - edited

        (1) [S]

        {HOST .PORT}

        macro should be supported also by trigger name/description

        Andris Zeila RESOLVED in r41428

        Aleksandrs Saveljevs Looks good, but please see r41528. Checks for macros where in different order in different places. RESOLVED.

        Andris Zeila reviewed, CLOSED

        Show
        Andris Zeila added a comment - - edited (1) [S] {HOST .PORT} macro should be supported also by trigger name/description Andris Zeila RESOLVED in r41428 Aleksandrs Saveljevs Looks good, but please see r41528. Checks for macros where in different order in different places. RESOLVED. Andris Zeila reviewed, CLOSED
        Hide
        Andris Zeila added a comment - - edited

        (2) [F]

        {HOST.PORT} macro should be supported also by trigger name/description

        Oleg Egorov RESOLVED IN r41462

        Aleksandrs Saveljevs (a) {HOST.PORT}

        is expanded in trigger name in "Monitoring" -> "Triggers", but is not expanded in "Monitoring" -> "Events" or "Last 20 issues" in the dashboard.

        Oleg Egorov RESOLVED IN r41566

        Aleksandrs Saveljevs CLOSED

        Aleksandrs Saveljevs (b) I am not sure separating cases into "interfaceWithPriorities" and "interfaceWithPrioritiesPort" performance-wise is worth code complication that it introduces. Maybe just add

        {HOST.PORT}

        to PATTERN_INTERFACE_FUNCTION?

        Oleg Egorov CLOSED

        Aleksandrs Saveljevs (c) There is a typo in variable name $paternInterfaceFunction. REOPENED.

        Oleg Egorov RESOLVED IN r41566

        Oleg Egorov As discussed, should be renamed from -> to
        interfaceWithPriorities -> interfaceWithoutPort
        interface -> agentInterface
        interfaceWithPrioritiesPort -> interface

        Aleksandrs Saveljevs It was $paternInterfaceFunction, now it became $paterntInterfaceFunction, which is even worse. The correct spelling is $patternInterfaceFunction. Fixed that in r41604. RESOLVED.

        Oleg Egorov Thanks! CLOSED

        Aleksandrs Saveljevs Tested

        Show
        Andris Zeila added a comment - - edited (2) [F] {HOST.PORT} macro should be supported also by trigger name/description Oleg Egorov RESOLVED IN r41462 Aleksandrs Saveljevs (a) {HOST.PORT} is expanded in trigger name in "Monitoring" -> "Triggers", but is not expanded in "Monitoring" -> "Events" or "Last 20 issues" in the dashboard. Oleg Egorov RESOLVED IN r41566 Aleksandrs Saveljevs CLOSED Aleksandrs Saveljevs (b) I am not sure separating cases into "interfaceWithPriorities" and "interfaceWithPrioritiesPort" performance-wise is worth code complication that it introduces. Maybe just add {HOST.PORT} to PATTERN_INTERFACE_FUNCTION? Oleg Egorov CLOSED Aleksandrs Saveljevs (c) There is a typo in variable name $paternInterfaceFunction. REOPENED. Oleg Egorov RESOLVED IN r41566 Oleg Egorov As discussed, should be renamed from -> to interfaceWithPriorities -> interfaceWithoutPort interface -> agentInterface interfaceWithPrioritiesPort -> interface Aleksandrs Saveljevs It was $paternInterfaceFunction, now it became $paterntInterfaceFunction, which is even worse. The correct spelling is $patternInterfaceFunction. Fixed that in r41604. RESOLVED. Oleg Egorov Thanks! CLOSED Aleksandrs Saveljevs Tested
        Hide
        Oleg Egorov added a comment -

        FIXED IN 2.2.2rc1 r41605, 2.3.0 r41606
        CLOSED

        Show
        Oleg Egorov added a comment - FIXED IN 2.2.2rc1 r41605, 2.3.0 r41606 CLOSED
        Hide
        richlv added a comment - - edited

        (3) according to (2),

        {HOST.PORT}

        support was also added in trigger name/description, but there is no changelog entry on that

        Documentation also should be updated

        Andris Zeila updated changelog in pre-2.2.2rc1 r42007 and pre-2.3.0 r42008

        Andris Zeila marked as supported in overview and added 'supported since' note https://www.zabbix.com/documentation/2.2/manual/appendix/macros/supported_by_location?&#overview

        Andris Zeila and updated whatsnew https://www.zabbix.com/documentation/2.2/manual/introduction/whatsnew222?&#daemon_improvements

        Please review

        Aleksandrs Saveljevs Fixed typo in changelog entry in r42090.

        Aleksandrs Saveljevs In https://www.zabbix.com/documentation/2.2/manual/appendix/macros/supported_by_location , I think that "internal and trigger" is a more suitable style for official documentation than "internal/trigger". Simiarly for "names/descriptions".

        Aleksandrs Saveljevs In "What's new", the change is only listed as a daemon improvement, but it also an improvement in the frontend. REOPENED.

        Andris Zeila Removed '/' from HOST.PORT macro description. Similar style was already used there, so I though it's acceptable. Regarding frontend documentation - I'm passing that to Oleg.

        Oleg Egorov RESOLVED

        <richlv> now we have footnote "Supported since 2.2.2." and in the description "Supported in trigger names and descriptions since 2.2.2.".
        other entries have various combinations of this, too. let's agree on some guidelines and unify this.

        Martins Valkovskis I'd propose the general rule as this - 'supported since' comments go in the Description (as done originally). However, when 'supported since' comments include a long listing (or would have to be repeated in too many cells), it is acceptable to add them in the footnotes and link to them.

        Martins Valkovskis Also, reviewed and removed the 'supported since' duplication in this particular case. And, for 'what's new', reviewed and improved the wording a bit and split it out into 'macro improvements' separately, rather than in 'daemon improvements'. Seeing that developer review of doc content has already taken place, I will set this as CLOSED.

        Show
        richlv added a comment - - edited (3) according to (2), {HOST.PORT} support was also added in trigger name/description, but there is no changelog entry on that Documentation also should be updated Andris Zeila updated changelog in pre-2.2.2rc1 r42007 and pre-2.3.0 r42008 Andris Zeila marked as supported in overview and added 'supported since' note https://www.zabbix.com/documentation/2.2/manual/appendix/macros/supported_by_location?&#overview Andris Zeila and updated whatsnew https://www.zabbix.com/documentation/2.2/manual/introduction/whatsnew222?&#daemon_improvements Please review Aleksandrs Saveljevs Fixed typo in changelog entry in r42090. Aleksandrs Saveljevs In https://www.zabbix.com/documentation/2.2/manual/appendix/macros/supported_by_location , I think that "internal and trigger" is a more suitable style for official documentation than "internal/trigger". Simiarly for "names/descriptions". Aleksandrs Saveljevs In "What's new", the change is only listed as a daemon improvement, but it also an improvement in the frontend. REOPENED. Andris Zeila Removed '/' from HOST.PORT macro description. Similar style was already used there, so I though it's acceptable. Regarding frontend documentation - I'm passing that to Oleg. Oleg Egorov RESOLVED <richlv> now we have footnote "Supported since 2.2.2." and in the description "Supported in trigger names and descriptions since 2.2.2.". other entries have various combinations of this, too. let's agree on some guidelines and unify this. Martins Valkovskis I'd propose the general rule as this - 'supported since' comments go in the Description (as done originally). However, when 'supported since' comments include a long listing (or would have to be repeated in too many cells), it is acceptable to add them in the footnotes and link to them. Martins Valkovskis Also, reviewed and removed the 'supported since' duplication in this particular case. And, for 'what's new', reviewed and improved the wording a bit and split it out into 'macro improvements' separately, rather than in 'daemon improvements'. Seeing that developer review of doc content has already taken place, I will set this as CLOSED.

          People

          • Assignee:
            Unassigned
            Reporter:
            Alexander Vladishev
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: