Details

    • Type: Change Request Change Request
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Duplicate
    • Affects Version/s: 3.0.0
    • Fix Version/s: None
    • Component/s: Frontend (F)
    • Labels:

      Description

      Quite often when trying to make use of the Latest Data screen in Zabbix 2.X or 3.0, the page will refresh as I'm about to click something or while scrolling.

      Could we consider using a stateful DOM model (like React.js or similar) to simply update the data cells as needed, instead of rebuilding the whole table with each refresh?

        Issue Links

          Activity

          Alexei Vladishev added a comment -

          It's one of top usability issues at the moment, should be fixed in one of the future releases as soon as we move some logic to the client side.

          richlv added a comment -

          related to ZBX-6403 - and does the linked subissue in ZBX-10007 help ?

          Patrick Hemmer added a comment -

          In the mean time, is there any way to disable it? I'd much rather have to manually refresh than deal with this auto-scroll-to-top-of-page thing.

          richlv added a comment - - edited

          you can't do it only for this page, but you can do it for your user account - set the refresh to 0 in your profile

          and to make it more user friendly than entering the magic number, vote on ZBXNEXT-1542

          richlv added a comment -

          as commented by pidzero on IRC, probably worth folding into ZBX-6403

          Valdis Murzins added a comment -

          Closing as duplicate of ZBX-12663


            People

            • Assignee:
              Unassigned
              Reporter:
              Ryan Armstrong
            • Votes:
              7 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: