Uploaded image for project: 'ZABBIX FEATURE REQUESTS'
  1. ZABBIX FEATURE REQUESTS
  2. ZBXNEXT-4686

Need ruby zabbixapi gem updated to support > 3.2

    Details

    • Type: New Feature Request
    • Status: Closed
    • Priority: Major
    • Resolution: Incomplete
    • Affects Version/s: 3.4.11, 3.4.12, 4.0.0alpha9
    • Fix Version/s: None
    • Component/s: API (A)
    • Labels:
      None

      Description

      We make heavy use of ruby scripts with zabbix and rely on the zabbixapi gem (here: https://github.com/express42/zabbixapi ).  The original developer has lost interest and to date no one has picked up the ball.  This leaves a situation where the mst popular zabbix api library in ruby land does not support > 3.2. 

       

      I'm making this issue to get it on the charts.   Can you update this ticket with Zabbix's thinking on what it'd take to get that library up to date?  Is there a chance that you guys would do the work?

      We're planning on upgrading to 4 lts very soon after its available - if our ruby logic becomes unusable that'll be a serious blocker for us.

       

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              dparker David Parker
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: