Uploaded image for project: 'ZABBIX FEATURE REQUESTS'
  1. ZABBIX FEATURE REQUESTS
  2. ZBXNEXT-5978

OpenBSD upstream support (packages)

    XMLWordPrintable

Details

    • New Feature Request
    • Status: Open
    • Trivial
    • Resolution: Unresolved
    • 5.0.0
    • None
    • None
    • None
    • OpenBSD

    Description

      Despite the Zabbix web site showing OpenBSD support, there are no official OpenBSD packages.

       

      I am requesting that packages are created for upstream support.  Currently, when using the pkg_add command on OpenBSD, the highest version is 4.0.19.  Sure, we could build from source, but why not have a package available?  This would make it easier to roll out.

       

      As a side note, when compiling from source, the default settings do not line up with OpenBSD best practices.  For example, the zabbix user is "zabbix" as opposed to "_zabbix".

       

      It is OpenBSD policy that services have usernames beginning with an underscore to highlight that it is a service user instead of a real user (I believe it is this way to aid in security).

       

      Also, LibreSSL is used in OpenBSD as opposed to OpenSSL.  Although the Zabbix manual makes a passing mention of LibreSSL, the agent download pages only show OpenSSL or Gnu.  LibreSSL is a more secure SSL that the OpenBSD developers created and maintain due to the past security concerns of OpenSSL.

       

      Thank you.

       

      Attachments

        Activity

          People

            Unassigned Unassigned
            pcovello Paul Frank Covello
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: