Uploaded image for project: 'ZABBIX FEATURE REQUESTS'
  1. ZABBIX FEATURE REQUESTS
  2. ZBXNEXT-6850

Add latest MariaDB/MySQL support

    XMLWordPrintable

Details

    • Change Request
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 5.4.3
    • None
    • Frontend (F)
    • None
    • MariaDB/MySQL from 10.6.1

    Description

      Steps to reproduce:

      1. When use MariaDB >= 10.6.1
      2. Cannot install Zabbix 

      Result:

      "Incorrect default charset for Zabbix database: "utf8mb4" instead "utf8"."

      See attached screenshot as well..

      SQL query:
      MariaDB [zabbix]> SELECT @@character_set_database, @@collation_database;
      ----------------------------------------------+

      @@character_set_database @@collation_database

      ----------------------------------------------+

      utf8mb4                   utf8mb4_unicode_ci   

      ----------------------------------------------+
      1 row in set (0.000 sec)

      MariaDB [zabbix]>

      Conversion it is no longer possible to simple UTF8!

      See Changes here:
      https://mariadb.com/kb/en/supported-character-sets-and-collations/

      We tried modify DEFAULT _CHARSET in "defines.inc.php' for workaround, but we did not succeed

       

      Attachments

        Activity

          People

            vmurzins Valdis Murzins
            V3CTOR Karoly Charles Barcza
            Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated: