Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-16725

Zabbix Server doesn't recognize fping version properly

    XMLWordPrintable

    Details

    • Team:
      Team A
    • Sprint:
      Sprint 57 (Oct 2019)
    • Story Points:
      0.5

      Description

      After upgrading Zabbix from 4.2.4 to 4.2.7 icmpping items stopped working.
      Zabbix tries to launch fping with interval=0 (-i0) which is illegal in fping older than 4.0.
      I believe this was introduced here.

      Steps to reproduce:

      1. Install Zabbix server 4.2.7 from official Zabbix packages
      2. Use icmpping item

      Result:
      Items depending on fping become not_supported.

      Expected:
      icmpping working like in version 4.2.4

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              MVekslers Michael Veksler
              Reporter:
              robert.szulist Robert Szulist
              Votes:
              3 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: