Uploaded image for project: 'ZABBIX BUGS AND ISSUES'
  1. ZABBIX BUGS AND ISSUES
  2. ZBX-21358

Update server TimescaleDB supported upper version to correspond to the documentation

    XMLWordPrintable

Details

    • Team B
    • Sprint 90 (Jul 2022), Sprint 91 (Aug 2022)
    • 0.125

    Description

      At the moment, the documentation requirements mentions that the maximum supported TimescaleDB version is 2.7:

      TimescaleDB for PostgreSQL	2.0.1-2.7
      

      but the server mentions the 2.6:

      include/zbxbd.h
      #define ZBX_TIMESCALE_MIN_VERSION_WITH_LICENSE_PARAM_SUPPORT    20000
      #define ZBX_TIMESCALE_MAX_VERSION                               20699
      #define ZBX_TIMESCALE_MAX_VERSION_FRIENDLY                      "2.6"
      

      It was agreed, to initially, quickly update the documentation to mention the limit back to 2.6.
      Then, for the next rcs, the documentation could be reverted back again to 2.7, with changes in the server code.

      Attachments

        Issue Links

          Activity

            People

              mgeneralova Marina Generalova
              arimdjonoks Artjoms Rimdjonoks
              Votes:
              2 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated: