Uploaded image for project: 'ZABBIX FEATURE REQUESTS'
  1. ZABBIX FEATURE REQUESTS
  2. ZBXNEXT-123

Value mapping not visible in the graphs

    XMLWordPrintable

    Details

    • Type: Change Request
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Frontend (F)

      Description

      If you enable the value mapping for an item this is visible in the overview. When the same item is graphed (by default as the actual value is a number), the mapped value is not visible in the graph.

      This means that you have no clue which the specific value means.

      For example I'm monitoring heartbeat machines which have a status active or passive. These values are stored as 0 and 1 and mapped to standby and active. On the overview page this is visible, but the graph only shows 0 and 1 and no direct link to which theses values mean.

        Attachments

        1. example_3.0.4.png
          example_3.0.4.png
          131 kB
        2. example.png
          example.png
          132 kB
        3. zbx_graph_axis_valuemap.patch
          6 kB
        4. zbx_graph_value_maps_2.4.7_v1.zip
          17 kB
        5. zbx_graph_value_maps_3.0.4_v1.zip
          145 kB

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              raskas Johan Huysmans
              Votes:
              18 Vote for this issue
              Watchers:
              17 Start watching this issue

                Dates

                Created:
                Updated: