Uploaded image for project: 'ZABBIX FEATURE REQUESTS'
  1. ZABBIX FEATURE REQUESTS
  2. ZBXNEXT-3623

Decide in runtime which features of libcurl are available

    XMLWordPrintable

    Details

    • Type: Change Request
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.4.0alpha1
    • Fix Version/s: None
    • Component/s: Server (S)

      Description

      libcurl has a very stable ABI, major so-version remains the same since 2006 while API is being actively enhanced.

      Currently Zabbix decides which features of libcurl are available at compilation stage:

      #	if 0x071004 >= LIBCURL_VERSION_NUM	/* version 7.16.4 */
      #		define CURLOPT_KEYPASSWD	CURLOPT_SSLKEYPASSWD
      #	endif
      #	if 0x071400 <= LIBCURL_VERSION_NUM	/* version 7.20.0 */
      #		define HAVE_SMTP_AUTHENTICATION	1
      #	endif
      

      Therefore, if Zabbix was compiled with old libcurl headers, upgrading libcurl will not enable missing features without Zabbix recompilation (ZBX-11629).

      Zabbix should be able to adjust it's behaviour in runtime based on version information it can get from a libcurl binary currently loaded.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              glebs.ivanovskis Glebs Ivanovskis (Inactive)
              Votes:
              3 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated: