Uploaded image for project: 'ZABBIX FEATURE REQUESTS'
  1. ZABBIX FEATURE REQUESTS
  2. ZBXNEXT-6241

Better naming for JavaScript methods

    XMLWordPrintable

    Details

    • Type: Change Request
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.4.0alpha1, 5.4 (plan)
    • Component/s: Server (S)
    • Labels:
      None
    • Team:
      Team C
    • Sprint:
      Sprint 69 (Oct 2020), Sprint 70 (Nov 2020), Sprint 71 (Dec 2020)
    • Story Points:
      1

      Description

      I think we should rename existing CurlHttpRequest to HttpRequest for simplicity. Also some methods should be renamed in order to make them JavaScript alike:

      Log = log
      AddHeader = addHeader
      ClearHeader = clearHeader
      GetHeaders = getHeaders
      Get/Put/Post/Delete = get/put/post/delete
      SetProxy = setProxy
      Status = getStatus # add "get" prefix for consistency 

      Older methods should be marked as deprecated and supported till Zabbix 6.0 (included).

        Attachments

          Activity

            People

            Assignee:
            dgoloscapov Dmitrijs Goloscapovs
            Reporter:
            alexei Alexei Vladishev
            Votes:
            1 Vote for this issue
            Watchers:
            12 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: