Uploaded image for project: 'ZABBIX FEATURE REQUESTS'
  1. ZABBIX FEATURE REQUESTS
  2. ZBXNEXT-6241

Better naming for JavaScript methods

XMLWordPrintable

    • Icon: Change Request Change Request
    • Resolution: Fixed
    • Icon: Trivial Trivial
    • 5.4.0alpha1, 5.4 (plan)
    • None
    • Server (S)
    • None
    • Team C
    • Sprint 69 (Oct 2020), Sprint 70 (Nov 2020), Sprint 71 (Dec 2020)
    • 1

      I think we should rename existing CurlHttpRequest to HttpRequest for simplicity. Also some methods should be renamed in order to make them JavaScript alike:

      Log = log
      AddHeader = addHeader
      ClearHeader = clearHeader
      GetHeaders = getHeaders
      Get/Put/Post/Delete = get/put/post/delete
      SetProxy = setProxy
      Status = getStatus # add "get" prefix for consistency 

      Older methods should be marked as deprecated and supported till Zabbix 6.0 (included).

        There are no Sub-Tasks for this issue.

            dgoloscapov Dmitrijs Goloscapovs
            alexei Alexei Vladishev
            Team C
            Votes:
            1 Vote for this issue
            Watchers:
            11 Start watching this issue

              Created:
              Updated:
              Resolved: